aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml28
1 files changed, 28 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..3b31a88
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,28 @@
+[package]
+name = "dynamize"
+version = "0.1.0"
+description = "proc macro to make traits with associated types object-safe"
+authors = ["Martin Fischer <martin@push-f.com>"]
+license = "MIT"
+repository = "https://git.push-f.com/dynamize"
+keywords = ["proc-macro", "attribute", "dyn", "object-safe", "blanket"]
+categories = ["rust-patterns"]
+edition = "2021"
+
+[lib]
+proc-macro = true
+doctest = false
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[features]
+# internal features
+nightly = []
+
+[dependencies]
+proc-macro2 = "1.0"
+quote = "1.0"
+syn = { version = "1.0", features = ["full", "extra-traits"] }
+
+[dev-dependencies]
+async-trait = "0.1"