diff options
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -6,11 +6,15 @@ edition = "2018" license = "MIT" description = "a git web interface with editing and Markdown support" repository = "https://git.push-f.com/gitpad" -keywords = ["git", "wiki", "markdown"] +keywords = ["git", "wiki", "markdown", "lua"] categories = ["command-line-utilities"] # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html +[features] +default = ["lua"] +lua = ["rlua"] + [dependencies] hyper = { version = "0.14.20", features=["http1", "server", "runtime", "stream"]} tokio = { version = "1", features=["rt-multi-thread", "macros"] } @@ -34,6 +38,7 @@ chrono = "0.4" multer = "2.0.3" mime_guess = "2.0" camino = "1" +rlua = { version = "0.19.4", optional = true } [target.'cfg(unix)'.dependencies] hyperlocal = { version = "0.8", features = ["server"] } |