aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2023-08-18 16:43:03 +0200
committerMartin Fischer <martin@push-f.com>2023-08-19 13:41:55 +0200
commit0c495ba984436cccc6caeed66639a2b61095dbad (patch)
tree8c57ecb02418c0ec8ab1133dd6a20933703ce6a4 /Cargo.toml
parentfba3706e29d049e05da36d522b25cc8fc75d689a (diff)
chore: switch from pretty_assertions to similar-asserts
In the next commit I'm adding a test that compares the content of files and pretty_assertions doesn't omit large portions of unchanged lines in its diff[1] (contrary to similar-asserts). (Sidenote: We already depend on similar via insta.) [1]: https://github.com/rust-pretty-assertions/rust-pretty-assertions/issues/114
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 99a257a..943f710 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,6 +2,9 @@
members = [".", "html5lib_tests", "integration_tests"]
default-members = [".", "html5lib_tests", "integration_tests"]
+[workspace.dependencies]
+similar-asserts = "1.4.2"
+
[package]
name = "html5tokenizer"
authors = ["Markus Unterwaditzer <markus-honeypot@unterwaditzer.net>", "Martin Fischer <martin@push-f.com>"]
@@ -17,7 +20,7 @@ include = ["src/**/*", "LICENSE", "README.md"]
[dev-dependencies]
codespan-reporting = "0.11.1"
insta = "1.31.0"
-pretty_assertions = "1.0.0"
+similar-asserts = { workspace = true }
[features]
# Feature used by integration tests in tests/ to get access to library internals.