aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2021-11-30 07:28:21 +0100
committerMartin Fischer <martin@push-f.com>2021-11-30 11:22:35 +0100
commitbaf1477c587fe22d27e94408cf2505d588ba007e (patch)
treef3e027e3c149cfeb7187a625756ea4b2de47c82a /Cargo.toml
parent25087cce997abc386f881648dfd39c83dfef7667 (diff)
add spans feature
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7b270b6..8aa0df0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,6 +12,7 @@ edition = "2018"
[features]
default = ["named-entities"]
+spans = []
# resolve named entities like &amp;
named-entities = ["phf", "phf_codegen"]
@@ -23,8 +24,13 @@ phf = { version = "0.9", optional = true }
phf_codegen = { version = "0.9", optional = true }
[dev-dependencies]
+codespan-reporting = "0.11.1"
criterion = "0.3"
[[bench]]
name = "html5ever"
harness = false
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "docsrs"]