aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..3caf8c6
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,30 @@
+[package]
+
+name = "html5ever"
+version = "0.25.1"
+authors = [ "The html5ever Project Developers" ]
+license = "MIT / Apache-2.0"
+repository = "https://github.com/servo/html5ever"
+description = "High-performance browser-grade HTML5 parser"
+documentation = "https://docs.rs/html5ever"
+build = "build.rs"
+categories = [ "parser-implementations", "web-programming" ]
+edition = "2018"
+
+[dependencies]
+log = "0.4"
+mac = "0.1"
+markup5ever = { version = "0.10", path = "../markup5ever" }
+
+[dev-dependencies]
+typed-arena = "1.3.0"
+criterion = "0.3"
+
+[build-dependencies]
+quote = "1"
+syn = { version = "1", features = ["extra-traits", "full", "fold"] }
+proc-macro2 = "1"
+
+[[bench]]
+name = "html5ever"
+harness = false