aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 8 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c9086e8..a4257b3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,11 +10,17 @@ categories = [ "parser-implementations", "web-programming" ]
keywords = ["html", "html5", "tokenizer", "parser"]
edition = "2018"
+[features]
+default = ["named-entities"]
+
+# resolve named entities like &
+named-entities = ["phf", "phf_codegen"]
+
[dependencies]
-phf = "0.9"
+phf = { version = "0.9", optional = true }
[build-dependencies]
-phf_codegen = "0.9"
+phf_codegen = { version = "0.9", optional = true }
[dev-dependencies]
typed-arena = "1.3.0"