aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..fc3b542
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "html5gum"
+authors = ["Markus Unterwaditzer <markus-honeypot@unterwaditzer.net>"]
+description = "A WHATWG-compliant HTML5 tokenizer and tag soup parser."
+edition = "2018"
+readme = "README.md"
+keywords = ["html", "html5", "whatwg", "parser", "tokenizer", "lexer", "sax", "xml", "parsing"]
+license = "MIT"
+repository = "https://github.com/untitaker/html5gum"
+version = "0.1.0"
+
+[dev-dependencies]
+pretty_assertions = "1.0.0"
+serde = { version = "1.0.130", features = ["derive"] }
+serde_json = "1.0.71"
+test-generator = "0.3.0"
+
+[features]
+# Feature used by integration tests in tests/ to get access to library internals.
+integration-tests = []