summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2025-03-22 11:47:54 +0100
committerMartin Fischer <martin@push-f.com>2025-03-23 23:36:40 +0100
commite451a31ed7a0d5fa268a2065906c6fb803e6ae26 (patch)
tree8dde16820972653c6b67e08b4e2319c43aa18db1 /default.nix
initial commitv0.0.1
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..07331d7
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,19 @@
+{ pkgs ? import <nixpkgs> {} }:
+with pkgs.python313Packages;
+
+buildPythonPackage rec {
+ pname = "logformat";
+ version = "git";
+ src = ./.;
+ pyproject = true;
+
+ build-system = [
+ setuptools
+ ];
+
+ disabled = pythonOlder "3.13";
+
+ installCheckPhase = ''
+ python ${./test_logformat.py}
+ '';
+}