summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..7640b73
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,25 @@
+[project]
+name = "logformat"
+version = "0.0.1"
+authors = [
+ { name="Martin Fischer", email="martin@push-f.com" },
+]
+description = "logfmt logging for Python"
+requires-python = ">=3.13" # because of __static_attributes__
+
+readme = "README.md"
+classifiers = [
+ "Programming Language :: Python :: 3",
+ "Operating System :: OS Independent",
+]
+license = "MIT"
+license-files = ["LICENSE"]
+
+[project.urls]
+repository = "https://git.push-f.com/logformat"
+
+[tool.setuptools]
+packages = ["logformat"]
+
+[tool.black]
+line-length = 100