summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..d923d2e
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,27 @@
+{ pkgs ? import <nixpkgs> {} }:
+with pkgs.python310Packages;
+
+let
+ pywikiapi = import ./deps/pywikiapi.nix { inherit pkgs; };
+in
+buildPythonApplication rec {
+ pname = "osm-proposals";
+ version = "git";
+ src = ./.;
+ pyproject = true;
+
+ build-system = [
+ setuptools
+ ];
+
+ dependencies = [
+ requests
+ mwparserfromhell
+ pywikiapi
+ ];
+
+ postInstall = ''
+ mkdir -p $out/share/osm-proposals
+ cp -r ${./static}/. $out/share/osm-proposals/
+ '';
+}