summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..01d0210
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,13 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+pkgs.buildGoModule rec {
+ pname = "rust-features";
+ version = "git";
+ src = ./.;
+ vendorHash = "sha256-WaDp7wKYHeV8hAAwPGmp1Dv8Hkwzl+Mzr8yzuUP2TgQ=";
+ nativeBuildInputs = [pkgs.makeWrapper];
+
+ postInstall = ''
+ wrapProgram $out/bin/rust-features --prefix PATH : ${pkgs.lib.makeBinPath [ pkgs.git pkgs.bash ]}
+ '';
+}