summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..5eaf9f4
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "toml-patch"
+version = "0.1.0"
+description = "A command-line tool to apply updates from a JSON file to a TOML file, while preserving comments."
+repository = "https://git.push-f.com/toml-patch/"
+authors = ["Martin Fischer <martin@push-f.com>"]
+license = "MIT"
+categories = ["command-line-utilities"]
+keywords = ["cli", "toml", "json"]
+edition = "2021"
+
+[dependencies]
+anyhow = "1.0.93"
+argh = "0.1.12"
+serde_json = "1.0.132"
+toml_edit = "0.22.22"
+
+[dev-dependencies]
+indoc = "2.0.5"