summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2021-09-12 16:04:38 +0200
committerMartin Fischer <martin@push-f.com>2021-09-12 19:29:26 +0200
commit8b9bcd0d86eaa27dc78b82ea65c9f60dfc7ce621 (patch)
tree556ffb0e620c6d9f9a5df6d6ebb5630506282c09 /Cargo.toml
initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..cef5659
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "webcat"
+version = "0.1.0"
+description = "netcat for websockets"
+authors = ["Martin Fischer <martin@push-f.com>"]
+license = "MIT"
+repository = "https://git.push-f.com/webcat"
+keywords = ["websocket", "netcat", "cli"]
+categories = ["command-line-utilities"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0.43"
+atty = "0.2.14"
+futures = "0.3.17"
+tokio = { version = "1.11.0", features = ["net", "macros", "time", "rt-multi-thread", "sync"] }
+tokio-tungstenite = "0.15.0"
+url = "2.2.2"