summaryrefslogtreecommitdiff
path: root/nixos/hosts/tente/gotify.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2025-03-27 21:33:25 +0100
committerMartin Fischer <martin@push-f.com>2025-04-01 07:51:54 +0200
commitb0e559f749f9ce3fc8a472de70ecbb5090425ffe (patch)
treeb31c6b6df12f476ddfac4868928768e7d7871a5a /nixos/hosts/tente/gotify.nix
parent1a4314b20cc9388f96f5961301fe1dd0a3474d1f (diff)
feat(tente): add Gotify
Diffstat (limited to 'nixos/hosts/tente/gotify.nix')
-rw-r--r--nixos/hosts/tente/gotify.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/nixos/hosts/tente/gotify.nix b/nixos/hosts/tente/gotify.nix
new file mode 100644
index 0000000..ba0fd02
--- /dev/null
+++ b/nixos/hosts/tente/gotify.nix
@@ -0,0 +1,21 @@
+{ config, lib, ... }:
+
+let
+ cfg = config.gotify;
+in
+{
+ options.gotify = {
+ port = lib.mkOption {
+ type = lib.types.int;
+ };
+ };
+
+ config = {
+ services.gotify = {
+ enable = true;
+ environment = {
+ GOTIFY_SERVER_PORT = cfg.port;
+ };
+ };
+ };
+}