summaryrefslogtreecommitdiff
path: root/nixos/hosts/tente/gotify.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/hosts/tente/gotify.nix')
-rw-r--r--nixos/hosts/tente/gotify.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/nixos/hosts/tente/gotify.nix b/nixos/hosts/tente/gotify.nix
new file mode 100644
index 0000000..ba0fd02
--- /dev/null
+++ b/nixos/hosts/tente/gotify.nix
@@ -0,0 +1,21 @@
+{ config, lib, ... }:
+
+let
+ cfg = config.gotify;
+in
+{
+ options.gotify = {
+ port = lib.mkOption {
+ type = lib.types.int;
+ };
+ };
+
+ config = {
+ services.gotify = {
+ enable = true;
+ environment = {
+ GOTIFY_SERVER_PORT = cfg.port;
+ };
+ };
+ };
+}