summaryrefslogtreecommitdiff
path: root/nixos/profiles/workstation/android.nix
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2025-03-08 16:04:27 +0100
committerMartin Fischer <martin@push-f.com>2025-03-08 16:04:27 +0100
commit03d807abf43ecf3cc988f06a3dc242d6d480a385 (patch)
tree502e1b5967ca9a80307b5a40ab3067b3fd44828b /nixos/profiles/workstation/android.nix
parente5a6c75fedaed89eef62696de4332f3dfba7d273 (diff)
feat(workstation): add fastboot and go-mtpfs
Diffstat (limited to 'nixos/profiles/workstation/android.nix')
-rw-r--r--nixos/profiles/workstation/android.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/nixos/profiles/workstation/android.nix b/nixos/profiles/workstation/android.nix
new file mode 100644
index 0000000..0b7a086
--- /dev/null
+++ b/nixos/profiles/workstation/android.nix
@@ -0,0 +1,9 @@
+{ config, pkgs, ... }:
+
+{
+ environment.systemPackages = with pkgs; [
+ # CLI tools
+ android-tools # for fastboot to install GrapheneOS
+ go-mtpfs
+ ];
+}