aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml38
1 files changed, 38 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..c38f0e6
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,38 @@
+[package]
+name = "gitpad"
+version = "0.1.0"
+authors = ["Martin Fischer <martin@push-f.com>"]
+edition = "2018"
+license = "MIT"
+description = "a git web interface with editing and Markdown support"
+repository = "https://git.push-f.com/gitpad"
+keywords = ["git", "wiki", "markdown"]
+categories = ["command-line-utilities"]
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+hyper = { version = "0.14.5", features=["http1", "server", "runtime", "stream"]}
+tokio = { version = "1", features=["rt-multi-thread", "macros"] }
+
+serde = { version = "1.0", features = ["derive"] }
+toml = "0.5"
+percent-encoding = "2.1.0"
+
+sputnik = { version = "0.4.1", features = ["hyper_body"] }
+
+difference = { version = "2.0" }
+pulldown-cmark = { version = "0.8" }
+
+httpdate = "0.3"
+git2 = "0.13"
+
+url = "2.2"
+
+clap = "3.0.0-beta.2"
+chrono = "0.4"
+multer = "2.0.0"
+mime_guess = "2.0"
+
+[target.'cfg(unix)'.dependencies]
+hyperlocal = "0.8"