summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMartin Fischer <martin@push-f.com>2025-03-26 08:11:28 +0100
committerMartin Fischer <martin@push-f.com>2025-03-26 08:23:47 +0100
commit1c5b72f01ae4cac9740b43af6963e08c6277275c (patch)
treefb5d832f657e7e63f981f90387d5262a6278783c /pyproject.toml
parentbb1f5e7d97b5a2d63024071dbed91697e8bc8bcc (diff)
build: switch from setuptools to hatchling
For reproducible builds and also so that you no longer need `--config-settings editable_mode=compat` for pip install to make it work with Pyright. Neither of these concerns really affect osm-proposals since I am not publishing the package on PyPI nor does it expose any library but I have other packages where they do apply and to simplify maintenance I want to use the same build backend for all of my projects.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1bad629..2a6d936 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -2,8 +2,12 @@
name = "osm-proposals"
version = "0.0.0"
-[tool.setuptools.packages.find]
-where = ["."]
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[tool.hatch.build.targets.wheel]
+packages = ["osm_proposals"]
[project.scripts]
osm-proposals = "osm_proposals.proposals:run"