summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 6 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1bad629..2a6d936 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -2,8 +2,12 @@
name = "osm-proposals"
version = "0.0.0"
-[tool.setuptools.packages.find]
-where = ["."]
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[tool.hatch.build.targets.wheel]
+packages = ["osm_proposals"]
[project.scripts]
osm-proposals = "osm_proposals.proposals:run"